Former Moonami Infrastructure experiencing outage.
Incident Report for Moodle US
Postmortem

Incident Overview:

Late Sunday evening, we observed a 100x anomalous increase in database connection requests which caused a very brief disruption in service.

Actions Taken:

  1. Database Cluster Upgrade: In response, we upgraded the database cluster to boost resources and performance.
  2. Introduction of Read-Replicas: To enhance database performance and stability, we added read-replicas and shifted website-related traffic to these servers. 

Next Steps:

Our commitment to service reliability remains steadfast. We'll maintain vigilant monitoring, investigate anomalies, and take proactive measures to prevent similar incidents in the future.

If you have questions or need further information, please don't hesitate to contact us. We appreciate your support.

Posted Oct 20, 2023 - 16:20 UTC

Resolved
This incident is resolved.
Posted Oct 16, 2023 - 17:12 UTC
Monitoring
Former Moonami infrastructure currently being monitored following tonight's (10/15/23) outage.
Posted Oct 16, 2023 - 03:02 UTC
Update
Former Moonami infrastructure has resumed operational status, infrastructure teams are continuing to investigate.
Posted Oct 16, 2023 - 02:41 UTC
Investigating
We are actively investigating an issue that is occurring with former Moonami infrastructure at this time.
Posted Oct 16, 2023 - 01:34 UTC
This incident affected: Moonami Client Infrastructure (Shared Moodle Hosting).