Partial outage on former Moonami infrastructure
Incident Report for Moodle US
Resolved
Service has been restored to all clients on the former Moonami infrastructure. The outages yesterday were caused by our servers running out of computing resources because of the rapid growth of client content file storage. We identified the root cause of the problem yesterday morning and took the following steps to prevent it from happening again. These steps include:

!. Significantly increasing the compute and memory capacity to handle the increased size of the content file storage
2. Implementing additional monitoring to warn us of similar conditions to what we observed prior to the recent outages
3. Over the coming weeks we will be actively transitioning content file storage to another storage service which is more memory efficient
Posted Sep 29, 2023 - 10:02 UTC
Monitoring
There is an ongoing issue with AWS services that is causing a degradation of service for some client sites. AWS is addressing the problem on their end and our engineers are monitoring the situation.
Posted Sep 28, 2023 - 23:59 UTC
Identified
We have engineers actively working on the problem and will restore site access ASAP.
Posted Sep 28, 2023 - 23:27 UTC
Update
We are actively working on a resolution at this time and do not expect further interruptions.
Posted Sep 28, 2023 - 18:31 UTC
Monitoring
We have identified the issue and are continuing to monitor the former Moonami infrastructure at this time.
Posted Sep 28, 2023 - 13:39 UTC
Update
We are continuing to investigate the source of the outage that occurred this morning on former Moonami infrastructure.
Posted Sep 28, 2023 - 13:19 UTC
Investigating
We are currently investigating an issue affecting some Moodle sites on former Moonami infrastructure.
Posted Sep 28, 2023 - 12:17 UTC
This incident affected: Moonami Client Infrastructure (Shared Moodle Hosting).